PrimeGrid
Please visit donation page to help the project cover running costs for this month

Toggle Menu

Join PrimeGrid

Returning Participants

Community

Leader Boards

Results

Other

drummers-lowrise
1) Message boards : Generalized Fermat Prime Search : Genefer CUDA issue in Linux (Message 72431)
Posted 2754 days ago by Greg
The binary loads the CUDA libraries, which require the 32-bit libsdtc++.
2) Message boards : Generalized Fermat Prime Search : Genefer CUDA issue in Linux (Message 72357)
Posted 2755 days ago by Greg
The libstdc++ problem was lack of 32 bit libraries, and was easy to fix. This is a compute node in a cluster running Rocks Emerald Boa, so upgrading the kernel isn't an option right now. I have no issue running other CUDA apps including CUDALucas, which also uses cufft, but I've not tried to use older cuda runtimes before.

I was just hoping for an automated way to feed work to the GPU when it is otherwise idle. I'll go back to manually giving it GIMPS double checks.
3) Message boards : Generalized Fermat Prime Search : Genefer CUDA issue in Linux (Message 72326)
Posted 2756 days ago by Greg
I just tried to run genefer in CUDA on Linux for the first time, but I'm getting an error:

cuda_subs.cu(191) : cudaSafeCall() Runtime API error : CUDA driver version is insufficient for CUDA runtime version.
SIGSEGV: segmentation violation
Stack trace (2 frames):
../../projects/www.primegrid.com/primegrid_genefer_3_1_2_2_2.06_i686-pc-linux-gnu__cudaGFNWR(boinc_catch_signal+0x1e8)[0x805ce9c]
[0xf7790400]

The full result is here:
http://www.primegrid.com/result.php?resultid=517613960

The installed driver is 319.37, which is a recent CUDA 5.5 driver. Any ideas?

Thanks!
4) Message boards : Project Staging Area : PRNet Discussion (Old) (Message 29462)
Posted 3883 days ago by Greg
Try this one
http://pgllr.mine.nu/PRPNet/prpclient_linux_64.zip

Works perfectly. Thanks!
5) Message boards : Project Staging Area : PRNet Discussion (Old) (Message 29420)
Posted 3884 days ago by Greg
The 64-bit version of 4.0.4 is dynamically linked to ioDBC. My computers don't have this installed.

ldd prpclient
linux-vdso.so.1 => (0x00007fff125ff000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fac0a1c2000)
libiodbc.so.2 => not found
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007fac09ebb000)
libm.so.6 => /lib64/libm.so.6 (0x00007fac09c39000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007fac09a23000)
libc.so.6 => /lib64/libc.so.6 (0x00007fac096c3000)
/lib64/ld-linux-x86-64.so.2 (0x00007fac0a3dd000)

[Return to PrimeGrid main page]
DNS Powered by DNSEXIT.COM
Copyright © 2005 - 2021 Rytis Slatkevičius (contact) and PrimeGrid community. Server load 1.64, 1.95, 2.19
Generated 4 Aug 2021 | 3:22:49 UTC