PrimeGrid
Please visit donation page to help the project cover running costs for this month

Toggle Menu

Join PrimeGrid

Returning Participants

Community

Leader Boards

Results

Other

drummers-lowrise
1) Message boards : Generalized Fermat Prime Search : no nvidia 'device' ...?! (Message 115098)
Posted 456 days ago by Cicu
Looks like Fedora is somewhat peculiar.

I had the Nvidia driver package installed directly from NVidia's tarball. It seemed to work, but...
After removing that one and doing

# dnf install xorg-x11-drv-nvidia-libs
# dnf install xorg-x11-drv-nvidia
# dnf install xorg-x11-drv-nvidia-cuda

(packages coming from rpmfusion), things were working just fine for everything I've tried, PrimeGrid GPU tasks too, to my joy.

I'll have to read more and do more work on it to really understand what's what, but for now I have no clue how to check that OpenCL is properly installed and working, as far as the installed hardware has the needed capabilities... Is there any step-by-step tutorial available somewhere?

2) Message boards : Generalized Fermat Prime Search : no nvidia 'device' ...?! (Message 114511)
Posted 466 days ago by Cicu
On a GeForce GTX 750 Ti which is shown in the boinc logs as

CUDA: NVIDIA GPU 0: GeForce GTX 750 Ti (driver version 390.25, CUDA version 9.1, compute capability5.0,1994MB, 1957MB available, 1388 GFLOPS peak)
OpenCL: NVIDIA GPU 0: GeForce GTX 750 Ti (driver version 390.25, device version OpenCL 1.2 CUDA, 1994MB, 1957MB available, 1388 GFLOPS peak)
OpenCL CPU: pthread-Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz (OpenCL driver vendor: The pocl project, driver version 0.15-pre, device version OpenCL 1.2 pocl HSTR: pthread-x86_64-unknown-linux-gnu-haswell)

*all* genefer tasks are aborting, giving results like

Output file genefer17low_13896781_1_0 for task genefer17low_13896781_1 absent

The STDERR on PrimeGrids task detail shows things like

<core_client_version>7.8.4</core_client_version>
<![CDATA[
<message>
process exited with code 193 (0xc1, -63)</message>
<stderr_txt>
geneferocl 3.3.2-7 (Linux/OpenCL/64-bit)

Copyright 2001-2017, Yves Gallot
Copyright 2009, Mark Rodenkirch, David Underbakke
Copyright 2010-2012, Shoichiro Yamada, Ken Brazier
Copyright 2011-2014, Michael Goetz, Ronald Schneider
Copyright 2011-2017, Iain Bethune
Genefer is free source code, under the MIT license.

Device open failed, aborting...
Device open failed, aborting...
Running on platform 'Clover', device '', vendor '3', version 'P&#131;&#252;&#253;' and driver 'NVIDIA Corporation'.
0 computeUnits @ 37732552MHz, memSize=0MB, cacheSize=0kB, cacheLineSize=0B, localMemSize=0kB, maxWorkGroupSize=0.
SIGSEGV: segmentation violation
Stack trace (8 frames):
../../projects/www.primegrid.com/primegrid_genefer_3_3_2_3.18_x86_64-pc-linux-gnu__OCLcudaGFN16[0x437035]
/lib64/libpthread.so.0(+0x12af0)[0x7f8941279af0]
/lib64/libOpenCL.so.1(clGetDeviceInfo+0x5)[0x7f8941063d45]
../../projects/www.primegrid.com/primegrid_genefer_3_3_2_3.18_x86_64-pc-linux-gnu__OCLcudaGFN16[0x431ff1]
../../projects/www.primegrid.com/primegrid_genefer_3_3_2_3.18_x86_64-pc-linux-gnu__OCLcudaGFN16[0x432348]
../../projects/www.primegrid.com/primegrid_genefer_3_3_2_3.18_x86_64-pc-linux-gnu__OCLcudaGFN16[0x4050d0]
/lib64/libc.so.6(__libc_start_main+0xea)[0x7f894094a00a]
../../projects/www.primegrid.com/primegrid_genefer_3_3_2_3.18_x86_64-pc-linux-gnu__OCLcudaGFN16[0x406e89]

Exiting...

</stderr_txt>
]]>

Seems that genefer tasks aren't recognizing the NVidia 'device'?

Other kinds of GPU tasks seem to run OK, so I'm unsure what would be wrong.

Thanks in advance for any ideas!

[Return to PrimeGrid main page]
DNS Powered by DNSEXIT.COM
Copyright © 2005 - 2019 Rytis Slatkevičius (contact) and PrimeGrid community. Server load 1.13, 1.40, 1.51
Generated 20 May 2019 | 1:13:41 UTC