PrimeGrid
Please visit donation page to help the project cover running costs for this month

Toggle Menu

Join PrimeGrid

Returning Participants

Community

Leader Boards

Results

Other

drummers-lowrise
1) Message boards : Number crunching : Can't load GPU units on Mac (Message 65992)
Posted 2189 days ago by Jon Fox
Willing to give it a try. What do I need to do to point at the test server?

--
jon
2) Message boards : Number crunching : Can't load GPU units on Mac (Message 65974)
Posted 2190 days ago by Jon Fox
I don't have any significantly more insightful information on the nature of the 7.1 branch. As with every other branch, I watch and review the changes logged by the developers (I'm a former developer but not in the BOINC community) but that's more related to being able to construct test suites that target the changes.

BTW, I wasn't able to test last night (longer weekend than planned) but did run a quick test this morning. Unfortunately, my rig is "full up" right now so fetch ignored the request.

    Mon May 27 08:06:00 2013 | PrimeGrid | update requested by user
    Mon May 27 08:06:02 2013 | PrimeGrid | Sending scheduler request: Requested by user.
    Mon May 27 08:06:02 2013 | PrimeGrid | Not requesting tasks: don't need
    Mon May 27 08:06:03 2013 | PrimeGrid | Scheduler request completed



I'll keep trying and post any results that directly address this error.

--
jon

3) Message boards : Number crunching : Can't load GPU units on Mac (Message 65865)
Posted 2192 days ago by Jon Fox
Thanks for the heads-up -- I am subscribed to the alpha mailing list and have seen a number of new issues reported in the 7.1 branch.

Actually, I specifically stay on the leading development versions for these types of scenarios. I try to provide as much testing and debugging platform time as possible to the community to help shake-out and improve the quality of the production/GA versions. This seems even more important in the OS X community due to the lack of available testers/machines.

That said, if there's no interest pursuing this bug, I'm fine with that as well. I run Collatz on this machine so I get full use of the ATI/AMD GPU and the PrimeGrid GPU apps run quite well on one of my windows machines. I'll proceed with the test cases mentioned earlier and if that's as far as it goes, no worries.

Thanks again.

--
jon
4) Message boards : Number crunching : Can't load GPU units on Mac (Message 65853)
Posted 2192 days ago by Jon Fox
Understood. I'll target restarting the work request after 2200 UTC Sunday 26 May. I'll request work with and without the app_info file. I'll also check the chatroom before I start the test.

--
Jon
5) Message boards : Number crunching : Can't load GPU units on Mac (Message 65818)
Posted 2192 days ago by Jon Fox
Here's the configuration data:
    Fri May 24 07:40:09 2013 | | Starting BOINC client version 7.1.1 for x86_64-apple-darwin
    Fri May 24 07:40:09 2013 | | This a development version of BOINC and may not function properly
    Fri May 24 07:40:09 2013 | | log flags: file_xfer, sched_ops, task
    Fri May 24 07:40:09 2013 | | Libraries: libcurl/7.26.0 OpenSSL/1.0.1c zlib/1.2.5 c-ares/1.9.1
    Fri May 24 07:40:09 2013 | | Data directory: /Library/Application Support/BOINC Data
    Fri May 24 07:40:09 2013 | | Processor: 4 GenuineIntel Intel(R) Core(TM) i5-2500S CPU @ 2.70GHz [x86 Family 6 Model 42 Stepping 7]
    Fri May 24 07:40:09 2013 | | Processor features: FPU VME DE PSE TSC MSR PAE MCE CX8 APIC SEP MTRR PGE MCA CMOV PAT PSE36 CLFSH DS ACPI MMX FXSR SSE SSE2 SS HTT TM PBE SSE3 PCLMULQDQ DTES64 MON DSCPL VMX SMX EST TM2 SSSE3 CX16 TPR PDCM SSE4.1 SSE4.2 xAPIC POPCNT AES PCID XSAVE OSXSAVE TSCTMR AVX1.0
    Fri May 24 07:40:09 2013 | | OS: Mac OS X 10.8.3 (Darwin 12.3.0)
    Fri May 24 07:40:09 2013 | | Memory: 12.00 GB physical, 870.06 GB virtual
    Fri May 24 07:40:09 2013 | | Disk: 930.71 GB total, 869.81 GB free
    Fri May 24 07:40:09 2013 | | Local time is UTC -5 hours
    Fri May 24 07:40:09 2013 | | OpenCL: AMD/ATI GPU 0: ATI Radeon HD 6770M (driver version 1.0, device version OpenCL 1.1, 512MB, 512MB available, 348 GFLOPS peak)


Forced a request for work:

    Fri May 24 16:30:16 2013 | PrimeGrid | update requested by user
    Fri May 24 16:30:21 2013 | PrimeGrid | Sending scheduler request: Requested by user.
    Fri May 24 16:30:21 2013 | PrimeGrid | Requesting new tasks for ATI
    Fri May 24 16:30:22 2013 | PrimeGrid | Scheduler request completed: got 0 new tasks



If you would like me to set some tracing flags just let me know. I'll also try to get to the app_info approach this weekend, as well.

--
jon

6) Message boards : Number crunching : Can't load GPU units on Mac (Message 65817)
Posted 2192 days ago by Jon Fox
will do.

jon
7) Message boards : Number crunching : Can't load GPU units on Mac (Message 65756)
Posted 2194 days ago by Jon Fox
I'm subscribed to PrimeGrid on a 2011 i5 iMac with an AMD/ATI 6770M GPU and OS X 10.8.3. I'm willing to also help in the testing/debugging effort, if needed.

Jon
8) Message boards : Problems and Help : ATI GPU: Upgrade to the latest driver Message (Message 42564)
Posted 2760 days ago by Jon Fox
Agreed on all counts.

I am committed to being an alpha/beta tester for the OS X platform so I've open a dialog on the alpha message board and created several simulation scenarios at the BCE site.

I'll keep pressing on that front.

Thanks again.
Jon
9) Message boards : Problems and Help : ATI GPU: Upgrade to the latest driver Message (Message 42524)
Posted 2761 days ago by Jon Fox
I entirely agree with your view of Collatz and Moo. I'm a full subscriber (across 3 windows and one os x hosts) to both.

Unfortunately, I get the exact same error message from Collatz. In addition, this version of the BOINC client only requests work for the ATI (even though I have preferences set for all CPU and GPU work). I'm queued up to get this documented on their site as well to see what if anything can be done to address it.

Moo! Wrapper is only requesting ATI work and with the existing client no work is sent so I still have to do some investigation with them as to why (again, I set my preferences to request all available CPU and GPU work units). At least, Moo doesn't complain about the version of the drivers<grin>.

I'll try to keep some linkage between these threads in case I get some solutions at Collatz or Moo! Wrapper that apply.

Thanks so much for all your assistance.
Jon
10) Message boards : Problems and Help : ATI GPU: Upgrade to the latest driver Message (Message 42447)
Posted 2762 days ago by Jon Fox
Thanks again for sustaining the inquiry.

Unfortunately, the download link on that page is dead and the other links are broken. I noticed the page was date 2007 so it appears this corner of the amd world has be "boarded up and abandoned".

Again, I appreciate your help.

Jon


Next 10 posts
[Return to PrimeGrid main page]
DNS Powered by DNSEXIT.COM
Copyright © 2005 - 2019 Rytis Slatkevičius (contact) and PrimeGrid community. Server load 1.01, 1.25, 1.37
Generated 26 May 2019 | 15:32:48 UTC