PrimeGrid
Please visit donation page to help the project cover running costs for this month

Toggle Menu

Join PrimeGrid

Returning Participants

Community

Leader Boards

Results

Other

drummers-lowrise
1) Message boards : Project Staging Area : PRNet Discussion( Old ) (Message 15422)
Posted 4525 days ago by lavalamp
Hey guys, I'm having a problem with the affinity. I've got an i7 and I'm running the quad 2.0.4 windows version. If I set the affinity manually in the task manager for each instance of LLR then I get over a 30% boost in speed.

However, if I set the affinity for the LLRs in each of the prpclient.ini files, it just doesn't work. I can see from the llr.ini files that the affinity setting is present there, but it seems LLR just ignores it.

Here's the llr.ini file for prpclient-1:
Work=0 PgenInputFile=work_12121.in PgenOutputFile=work_12121.out PgenLine=1 WorkDone=0 Affinity=1

And here's the appropriate section from the prpclient.ini folder:
// This sets the CPU affinity for LLR on multi-CPU machines. affinity=1

What can I do to make these settings kick in? As far as I can tell they're just ignored.


AFAICT, the setting is correct, so I don't know why LLR ignores it. That would be a question for Jean Penne.
Seems you're right, I put the affinity setting into an llr.ini file for the regular GUI version of LLR, and when run it's pinned to the correct CPU.

I did the same thing for cLLR but got no joy. I even tried adding -oaffinity=x to the command line.
2) Message boards : Project Staging Area : PRNet Discussion( Old ) (Message 15396)
Posted 4526 days ago by lavalamp
Hey guys, I'm having a problem with the affinity. I've got an i7 and I'm running the quad 2.0.4 windows version. If I set the affinity manually in the task manager for each instance of LLR then I get over a 30% boost in speed.

However, if I set the affinity for the LLRs in each of the prpclient.ini files, it just doesn't work. I can see from the llr.ini files that the affinity setting is present there, but it seems LLR just ignores it.

Here's the llr.ini file for prpclient-1:
Work=0 PgenInputFile=work_12121.in PgenOutputFile=work_12121.out PgenLine=1 WorkDone=0 Affinity=1

And here's the appropriate section from the prpclient.ini folder:
// This sets the CPU affinity for LLR on multi-CPU machines. affinity=1

What can I do to make these settings kick in? As far as I can tell they're just ignored.
[Return to PrimeGrid main page]
DNS Powered by DNSEXIT.COM
Copyright © 2005 - 2021 Rytis Slatkevičius (contact) and PrimeGrid community. Server load 5.02, 4.89, 4.60
Generated 25 Sep 2021 | 23:48:19 UTC