PrimeGrid
Please visit donation page to help the project cover running costs for this month

Toggle Menu

Join PrimeGrid

Returning Participants

Community

Leader Boards

Results

Other

drummers-lowrise
1) Message boards : Number crunching : PPS (sieve) CUDA tasks taking 3-4x as long to finish, while giving the same credit (Message 57840)
Posted 2702 days ago by OzgurDusunceli
To give an update, my CUDA performance on OS X 10.8.2 seems to be back to normal for no apparent reason. Now I'm seeing a single precision performance around 320 Gflop/s on CUDA-Z, compared to 95 Gflop/s earlier. (Btw, yes, I was running the CUDA tasks with no CPU tasks running, and without anything else resource intensive). I'm not sure what caused this large temporary drop in CUDA performance.
2) Message boards : Number crunching : PPS (sieve) CUDA tasks taking 3-4x as long to finish, while giving the same credit (Message 57742)
Posted 2706 days ago by OzgurDusunceli
It looks like CUDA here is now overall 3-4x slower than before. I've tried collatz, which is 3x slower than before, and CUDA-Z. GT 650M has 321 Gflops single-precision performance on CUDA-Z with OSX 10.8.1 according to this: http://www.barefeats.com/rogue02.html, while I'm getting 95 Gflops single-precision performance on CUDA-Z with GT 650M & OSX 10.8.2. I'd say it's the OSX 10.8.2 update, but a few PPS-sieve tasks were completed as quickly as before, after updating. This is weird.
3) Message boards : Number crunching : PPS (sieve) CUDA tasks taking 3-4x as long to finish, while giving the same credit (Message 57739)
Posted 2706 days ago by OzgurDusunceli
have you tried rebooting? There was a problem with previous windows drivers downclocking, no idea if the mac drivers suffered from the same problem.

Yes, I've tried rebooting (and reinstalling the CUDA driver). Didn't work :)
4) Message boards : Number crunching : PPS (sieve) CUDA tasks taking 3-4x as long to finish, while giving the same credit (Message 57738)
Posted 2706 days ago by OzgurDusunceli
Make sure "Power Managment" setting in Nvidia Control Panel is still on "Prefer Maxium Performance" not Adaptive. Mine has mysteriously reset on more than 1 occasion. It has to be set in both of the tabs there.

I'm using the gfxCardStatus program (in the "discrete only" mode) to make sure it's always at the "Higher performance" setting. So, that doesn't seem to be the issue. But thanks for the suggestion.
5) Message boards : Number crunching : PPS (sieve) CUDA tasks taking 3-4x as long to finish, while giving the same credit (Message 57725)
Posted 2707 days ago by OzgurDusunceli
Hi,

Since two days ago, PPS-sieve (1.39, cuda32) tasks have been taking 3-4 times as much time as before to complete, while giving the same credit. You can see the increase in run time here:
http://www.primegrid.com/results.php?hostid=267690&state=3

Was there something like a 3-4x increase in the workload for PPS-sieve CUDA tasks or could something be wrong on my system slowing down CUDA tasks? This is with the same CUDA driver version (5.0.24) before and after this started happening, on GeForce GT 650M on OSX.

(Btw, this started happening after I upgraded to OSX 10.8.2, but not before completing 8-10 hours worth of tasks as quickly as before on that new OSX version. So, I don't think it's related to the OS upgrade).

Thanks.
6) Message boards : Number crunching : Out of CUDA tasks? (Message 56131)
Posted 2786 days ago by OzgurDusunceli
Sent you both the request and reply. Thanks for looking into it.
Could you post (or better yet, PM to me) the contents of your sched_request.xml file? (You should be able to find it in your BOINC data directory.)
7) Message boards : Number crunching : Out of CUDA tasks? (Message 56087)
Posted 2787 days ago by OzgurDusunceli
Ok, so if I understand correctly, WITH app_info, you get work, and WITHOUT app_info, you don't, and this is consistent and repeatable?

Yes. And good news: I managed to fix my (apparently incorrect) app_info.xml, at least for PPS(sieve) tasks. I think I was also missing the two required dylib files. So, now I'm able to receive and compute CUDA tasks for PPS(sieve). However, without app_info.xml, the problem persists, though it's not that big of an issue for me right now, since the app_info method works.

If so, please verify that this is the correct computer:
http://www.primegrid.com/result.php?resultid=393324454
I'll ask Rytis if there's anything he can do.

Yes, that was one of the immediately failed tasks, but my new app_info.xml seems to have resolved that issue. So, you can ignore the second problem I mentioned.

If anyone wants to look into the first problem (i.e., 650M not receiving tasks *without* app_info), let me know if I can help in any way. But as I said, it's not an urgent problem for me right now, since app_info way works now.

You're better off starting a separate thread for this one where you'll draw the attention of someone who may be able to help. Asking questions inside existing threads that don't match the title of the thread is an effective strategy for not getting noticed by people who may know the answer to your question! :)

I agree. I'll do that next time. :)

If anyone's interested in an app_info.xml that works for PPS(sieve) CUDA with 650M on OSX, here it is (it might also work for Cullen/Woodall (Sieve), but I haven't gotten any tasks for it yet):

<app_info> <app> <name>gcwsieve</name> <user_friendly_name>Cullen/Woodall (Sieve)</user_friendly_name> </app> <app> <name>pps_sr2sieve</name> <user_friendly_name>PPS (Sieve)</user_friendly_name> </app> <file_info> <name>primegrid_gcwsieve_1.12_x86_64-apple-darwin__cuda32</name> <executable/> <nbytes>372728.000000</nbytes> </file_info> <file_info> <name>libtlshook.dylib_20101129</name> <nbytes>34748.000000</nbytes> </file_info> <file_info> <name>libcudart.dylib_20101129</name> <nbytes>784552.000000</nbytes> </file_info> <app_version> <app_name>gcwsieve</app_name> <version_num>112</version_num> <api_version>6.7.4</api_version> <file_ref> <file_name>primegrid_gcwsieve_1.12_x86_64-apple-darwin__cuda32</file_name> <main_program/> </file_ref> <file_ref> <file_name>libtlshook.dylib_20101129</file_name> <open_name>libtlshook.dylib</open_name> <copy_file/> </file_ref> <file_ref> <file_name>libcudart.dylib_20101129</file_name> <open_name>libcudart.dylib</open_name> <copy_file/> </file_ref> <platform>x86_64-apple-darwin</platform> <plan_class>cuda32</plan_class> <avg_ncpus>0.039012</avg_ncpus> <max_ncpus>0.039012</max_ncpus> <flops>3.1104e11</flops> <coproc> <type>CUDA</type> <count>1.000000</count> </coproc> </app_version> <file_info> <name>primegrid_tpsieve_1.39_x86_64-apple-darwin__cuda32</name> <executable/> <nbytes>377144.000000</nbytes> </file_info> <file_info> <name>libtlshook.dylib_20101129</name> <nbytes>34748.000000</nbytes> </file_info> <file_info> <name>libcudart.dylib_20101129</name> <nbytes>784552.000000</nbytes> </file_info> <app_version> <app_name>pps_sr2sieve</app_name> <version_num>139</version_num> <api_version>6.7.4</api_version> <file_ref> <file_name>primegrid_tpsieve_1.39_x86_64-apple-darwin__cuda32</file_name> <main_program/> </file_ref> <file_ref> <file_name>libtlshook.dylib_20101129</file_name> <open_name>libtlshook.dylib</open_name> <copy_file/> </file_ref> <file_ref> <file_name>libcudart.dylib_20101129</file_name> <open_name>libcudart.dylib</open_name> <copy_file/> </file_ref> <platform>x86_64-apple-darwin</platform> <plan_class>cuda32</plan_class> <avg_ncpus>0.039012</avg_ncpus> <max_ncpus>0.039012</max_ncpus> <flops>3.1104e11</flops> <coproc> <type>CUDA</type> <count>1.000000</count> </coproc> </app_version> <file_info> <name>gcwsieve_20110101.sieveinput_in</name> <nbytes>10299563</nbytes> <sticky/> </file_info> </app_info>

Cheers.
8) Message boards : Number crunching : Out of CUDA tasks? (Message 56082)
Posted 2787 days ago by OzgurDusunceli
Maybe I couldn't explain clearly. There are two problems. The log was from a task I was able to get only by creating an app_info.xml and copying the primegrid_tpsieve_1.39_x86_64-apple-darwin__cuda32 executable over from another machine. I still cannot get CUDA tasks the normal way (i.e., without a local app_info.xml), which is the first problem. I shouldn't have to use app_info.xml anyway, and don't want to if possible.

The second problem is that even if I use an app_info.xml, the tasks I get for PPS(sieve) terminate immediately with the "computation error" result and that log message.

In any case, I agree that this thread's title doesn't fit either of these problems. I will start a new thread for each problem tomorrow. Thanks for your time.

Wait a second....

This thread is about not being able to get CUDA tasks, so I thought that was what you were asking about.
But at the end of your post you have this:
[...]
That's the log from a task, so you ARE getting tasks but they're not working?
That's a completely different problem.
Looking at the snippet above, I do not have an explanation. Perhaps you should ask this question again, in your own thread with a more appropriate title, and people who might have more insight into this particular problem will be more likely to see it.
9) Message boards : Number crunching : Out of CUDA tasks? (Message 56077)
Posted 2787 days ago by OzgurDusunceli
Well, the same settings don't cause the same problem for the old machine. I tried deselecting PPS-LLR anyway, but that didn't help. (I also tried deselecting PPR-sieve, which didn't help either.) But thanks for the suggestion.

The problem exists on 650M, but not on 9600M. So, it's something related to 650M. (Or maybe Kepler GPUs in general? Has any other Kepler crunchers seen this issue?)

There is NO PPS-LLR CUDA tasks available, nor are their likely to be any in the near future as far as I know, so I suggest de-selecting that box.
[...]
So try deselecting PPS-CUDA (both boxes) and see if that helps.

10) Message boards : Number crunching : Out of CUDA tasks? (Message 56065)
Posted 2788 days ago by OzgurDusunceli
Hello! I am back with this problem. :)

I haven't been crunching in the last few months. Now I want to start again on a new machine (retina MacBook Pro with Geforce 650M), but the same problem is back! That is, I can't make BOINC (7.0.25 or 7.0.28) get new CUDA tasks for any subproject (except Genefer, that one works but seems very fragile, and also inefficient on Kepler; I saw those forum threads).

My current settings are the same as before:
Use CPU no
Use NVIDIA GPU yes
Proth Prime Search (LLR) CPU, CUDA
Cullen/Woodall Prime Search (Sieve) CPU, CUDA
Proth Prime Search (Sieve) CPU, CUDA
(The other ones are disabled).
Send work from any subproject if selected projects have no work no

I have tried installing each of the only CUDA drivers compatible with 650M on Nvidia's website (namely, cudadriver 4.2.10 and devdriver 4.2.9 & 4.2.10), but none of them solve this issue. (I did restart after installing each one).

The old machine that was the one in question at the beginning of this forum thread (with the 9600M) seems to be getting and running PPS(Sieve) and CW(Sieve) just fine (I tried with both cudadriver 4.0.50 and 4.2.10).

I then tried copying the executable that the old machine downloaded over to the new machine (and setting up a proper app_info.xml). With that, the new machine did get new CUDA tasks, but immediately ended with computation error (with the message below).

So, why can't I receive and run PPS(LLR), PPS(Sieve), or CW(Sieve) CUDA tasks for 650M? Do you think the 650M (with CUDA 4.2) is incompatible with these subprojects for some reason? Or am I doing something wrong?

Are there any log files that would help identify the issue?

Thanks in advance.

http://www.primegrid.com/result.php?resultid=393324454
<message>
process got signal 8
</message>
<stderr_txt>
Sieve started: 169595085000000000 <= p < 169595094000000000
Thread 0 starting
Detected GPU 0: GeForce GT 650M
Detected compute capability: 3.0
Detected 0 multiprocessors.
</stderr_txt>


Next 10 posts
[Return to PrimeGrid main page]
DNS Powered by DNSEXIT.COM
Copyright © 2005 - 2020 Rytis Slatkevičius (contact) and PrimeGrid community. Server load 3.18, 3.36, 3.43
Generated 20 Feb 2020 | 10:47:56 UTC